Oggi è 18 agosto 2019, 2:31

Tutti gli orari sono UTC + 1 ora [ ora legale ]




Apri un nuovo argomento Rispondi all’argomento  [ 5 messaggi ] 
Autore Messaggio
 Oggetto del messaggio: openBVE su mac OsX
MessaggioInviato: 13 settembre 2010, 20:46 
Non connesso
Apprendista

Iscritto il: 12 settembre 2010, 16:52
Messaggi: 2
Qualcuno mi saprebbe indicare, passo passo, come installare openBVE su MAC OSX.
Ho provato a farlo, ma mi ritorna sempre l'errore SDL framework


Top
 Profilo  
 
 Oggetto del messaggio: Re: openBVE su mac OsX
MessaggioInviato: 13 settembre 2010, 20:58 
Non connesso
2° agente
Avatar utente

Iscritto il: 26 agosto 2004, 20:28
Messaggi: 525
Innanzitutto benvenuto sul forum. ;)
Le istruzioni per l'installazione su Mac OS le trovi qui http://openbve.trainsimcentral.co.uk/us ... _unix.html
Dato il tipo di errore riportato, immagino che il problema sia nel Tao Framework, a tal proposito sul link riportato è scritto che:
-vanno messi nella cartella di OpenBVE i file Tao.OpenGL.dll, Tao.OpenAL.dll and Tao.SDL.dll
-è necessaria la versione 2.1.0, le altre non sono compatibili
-può essere necessario dover scaricare ulteriori file specifici per il tipo di sistema operativo (quali? :?: )


Top
 Profilo  
 
 Oggetto del messaggio: Re: openBVE su mac OsX
MessaggioInviato: 13 settembre 2010, 21:51 
Non connesso
Avatar utente

Iscritto il: 20 settembre 2002, 23:13
Messaggi: 1944
Località: Torino
Hai provato a leggere questo thread sul forum ufficiale inglese ?
http://openbve.freeforums.org/post5105.html

L'unico utente che usa p.c. della Apple e che frequenta questo forum credo che sia leank, ma non è ..molto attivo.

Comunque brainnolo, l'autore del thread sul forum inglese è un italiano.

_________________
Immagine

tof63@trenomania.it


Top
 Profilo  
 
 Oggetto del messaggio: Re: openBVE su mac OsX
MessaggioInviato: 15 ottobre 2010, 21:41 
Non connesso
Apprendista
Avatar utente

Iscritto il: 20 maggio 2004, 17:40
Messaggi: 9
Caro Luigi, passavo da queste parti... e siccome sono un pò influenzato sto smanettando parecchio con i miei Mac...
Ho provato a reinstallare OpenBve con i vecchi percorsi...
Mi sono ritrovato anch'io con quell'errore che ho subito risolto scaricando SDL.framework da:

http://www.libsdl.org/download-1.2.php

A questo punto probabilmente non ti funziona l'audio...

Ho provato a scaricare la FEVF ma non funge perchè il treno ha un plugin...

Domani faccio altre prove!!!


t

--
Ciao!!! ^___^
Leank

leankmax@gmail.com
Skype: Maxleank

- Apple MacPro: 2 processori Quad-Core Intel Xeon da 3GHz, 4GB ram, 2 hd 1TB +1 hd 1,5TB + 1 hd 500GB + 1 esterno da 640GB + 2 esterni da 1TB, NVidia GeForce 8800GT 512MB, Mac OS X 10.6.4.
- Apple MacBookPro Intel Core Duo 2 da 2,2 GHz, 4GB ram, 1 hd 320GB + 1 esterno 500 GB, NVidia GeForce 8600GT 128MB, Mac OS X 10.6.4.
- Apple iPad 64GB WiFi 3G.
- HTC Desire Android 2.2.
- MSI CX600 Intel Core Duo 2da 2GHz, 4GB ram, 1 hd 500GB, Winzozz Seven, Linux Ubuntu 10.4.


Ultima modifica di leank il 30 ottobre 2010, 11:38, modificato 1 volta in totale.

Top
 Profilo  
 
 Oggetto del messaggio: Re: openBVE su mac OsX
MessaggioInviato: 30 ottobre 2010, 10:37 
Non connesso
Apprendista
Avatar utente

Iscritto il: 20 maggio 2004, 17:40
Messaggi: 9
Sakve a tutti...

Ho fatto un bel pò di esperimenti, ma openbve non è fatto per Mac... principalmente per i plugin dei nuovi treni... ma ha anche problemi sui vecchi treni e sulle vecchie routes!!!
L'ultima versione di mono ha qualche bug...

Comunque c'è una ottima soluzione al problema...

Installare Wine e Winebottler dal seguente sito: http://winebottler.kronenberg.org/
La versione di Winebottler è la 1.1.35, mentre quella di Wine è la 1.1.4.2...
Conviene aggiornare a Wine 1.2.1 da questo link: http://winebottler.kronenberg.org/wine/

A questo punto con Winebottler create un nuovo prefix nella cartella: username/Libreria/Application Support/Wine/prefixes/nomeprefix... "nomeprefix" è un nome fittizio, nominatelo come volete!!!
Lanciate Wine, dal menù principale selezionate il prefix da voi creato (nomeprefix), successivamente selezionate nel menù la voce Winetrick...
e dalla lunga selezione che ottenete selezionate "donet20" e date Apply... compariranno altre varie finestre di conferma fino a che non avrà finito.

A questo punto potete procedere con l'installazione di openbve per winzozz!!!
Scompattate il file di installazione (openbve_stable.zip) direttamente nel vostro prefix: username/Libreria/Application Support/Wine/prefixes/nomeprefix/drive_c/Program Files/openbve.
Non scaricate nè NET.framework nè mono!!!
Scompattate quello che vi serve dal file Taoframework-2.1.0.zip come descritto nel sito di openbve...
A questo punto arriva la parte più difficile dell'installazione...
Decompattate oalinst.zip in una qualsiasi cartella: otterrete il file oalinst.exe... cliccatelo con il tasto destro del topo e selezionate "Apri con" e successivamente Wine...
Si aprirà Wine, selezionate "Run directly in" facendo attenzione che sia selezionato il vostro prefix (nomeprefix), ed ora GO!!!
Si aprirà un pannello di installazione a cui darete ok... e poi comparirà una conferma che tutto è andato a buon fine!!!
A questo punto andate su username/Libreria/Application Support/Wine/prefixes/nomeprefix/drive_c/windows/system32/ e copiate i file OpenAL32.dll e wrap_oal.dll
nella cartella: username/Libreria/Application Support/Wine/prefixes/nomeprefix/drive_c/Program Files/openbve.

A questo punto potete copiare treni e routes sempre nella stessa cartella sempre secondo le indicazioni di installazione!!!

Per lanciare openbve dovrete selezionare file manager da Wine, comparirà un file manager stile winzozz, selezionate Program File e poi openbve, e cliccate 2 volte su openbve.exe!!!

Ciò mi funziona decisamente bene sia su MacPro 8core 3ghz sia su MacBookPro 2core 2.2Ghz!!!

Inoltre Wine per Mac non dà problemi con i caratteri giapponesi o cinesi, come succede con Linux!!!

Per chiarimenti sono qua.


--
Ciao!!! ^___^
Leank

leankmax@gmail.com
Skype: Maxleank

- Apple MacPro: 2 processori Quad-Core Intel Xeon da 3GHz, 4GB ram, 2 hd 1TB +1 hd 1,5TB + 1 hd 500GB + 1 esterno da 640GB + 2 esterni da 1TB, NVidia GeForce 8800GT 512MB, Mac OS X 10.6.4.
- Apple MacBookPro Intel Core Duo 2 da 2,2 GHz, 4GB ram, 1 hd 320GB + 1 esterno 500 GB, NVidia GeForce 8600GT 128MB, Mac OS X 10.6.4.
- Apple iPad 64GB WiFi 3G.
- HTC Desire Android 2.2.
- MSI CX600 Intel Core Duo 2da 2GHz, 4GB ram, 1 hd 500GB, Winzozz Seven, Linux Ubuntu 10.4.


Top
 Profilo  
 
Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento Rispondi all’argomento  [ 5 messaggi ] 

Tutti gli orari sono UTC + 1 ora [ ora legale ]


Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Cerca per:
Vai a:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Traduzione Italiana phpBB.it